Cmd space not working even after disabling in spotlight

For all things Mellel

Moderators: redlers, Eyal Redler, Ori Redler

Post Reply
JWH
Got the auto-title mojo working
Posts: 23
Joined: Sun Oct 23, 2005 8:04 pm
Location: Grand Rapids, MI

Cmd space not working even after disabling in spotlight

Post by JWH » Wed May 18, 2016 12:32 am

Greetings,
My institution just upgraded my HDD to a SSD (with upgrade from Lion to El Capitan), so I did a fresh Mellel install. I disabled both shortcut keys in Spotlight to be able to use this shortcut to switch languages in Mellel. But the "cmd+space bar" still does not switch. I can only switch manually using the input source menu. I'm a 10 year old dog on Mellel, so I'm really puzzled. Any ideas?
John

vinesy
Read the guide!
Posts: 41
Joined: Fri Sep 25, 2009 11:55 pm

Re: Cmd space not working even after disabling in spotlight

Post by vinesy » Wed May 18, 2016 2:48 am

I know this is not exactly what you're asking for, but I have set CMD+L as a global keyboard switcher (System Preferences>keyboard>Shortcuts>input sources) and this way I can switch between languages just fine.

(This also requires Mellel>preferences>language>"Synchronise language and keyboard" to be checked).

Bulow
Knows everything, can prove it
Posts: 160
Joined: Tue Nov 25, 2008 11:49 am
Location: Paris (sometimes Copenhagen)

Re: Cmd space not working even after disabling in spotlight

Post by Bulow » Wed May 18, 2016 10:17 am

I don't think this problem concerns Mellel, but rather the system preferences.
System preferences > Keyboard > input source > shortcuts and tick the box 'Select previous input source'. Then the shortcut should work.
Since I write in several modern languages, all using the Latin alphabet, I have disconnected keyboard and language, but that depends on what you want. It makes sense, of course, if you only write English and Hebrew.
Bülow

JWH
Got the auto-title mojo working
Posts: 23
Joined: Sun Oct 23, 2005 8:04 pm
Location: Grand Rapids, MI

Re: Cmd space not working even after disabling in spotlight

Post by JWH » Wed May 18, 2016 12:58 pm

Bulow wrote:I don't think this problem concerns Mellel, but rather the system preferences.
System preferences > Keyboard > input source > shortcuts and tick the box 'Select previous input source'. Then the shortcut should work.
Since I write in several modern languages, all using the Latin alphabet, I have disconnected keyboard and language, but that depends on what you want. It makes sense, of course, if you only write English and Hebrew.
Bülow
Thank you, Bulow. This was the solution. I altered your advice slightly, choosing the "Select next input source" instead of "Select previous input source." If that is a mistake for some reason I can't foresee, please let me know. I appreciate your help!

I just discovered that if I assign the hot key to "Select *next* input source" that the command proceeds through my available languages, which also includes Greek. But if I check "Select *previous* input source" as you recommended, the hot key toggles back and forth between my default (English) and my secondary (Hebrew). That's better for my purposes! Thanks again.
Last edited by JWH on Wed May 18, 2016 1:53 pm, edited 1 time in total.

JWH
Got the auto-title mojo working
Posts: 23
Joined: Sun Oct 23, 2005 8:04 pm
Location: Grand Rapids, MI

Re: Cmd space not working even after disabling in spotlight

Post by JWH » Wed May 18, 2016 1:01 pm

vinesy wrote:I know this is not exactly what you're asking for, but I have set CMD+L as a global keyboard switcher (System Preferences>keyboard>Shortcuts>input sources) and this way I can switch between languages just fine.

(This also requires Mellel>preferences>language>"Synchronise language and keyboard" to be checked).
Thanks, vinesy. This is the same as Bulow recommended----it works. I appreciate your help.
John

Post Reply

Who is online

Users browsing this forum: No registered users and 19 guests