spellchecking bug with style variation

For all things Mellel

Moderators: redlers, Eyal Redler, Ori Redler

Post Reply
Manu31
Read the guide!
Posts: 35
Joined: Mon Aug 18, 2014 5:34 pm
Location: Toulouse, France

spellchecking bug with style variation

Post by Manu31 » Mon Mar 12, 2018 8:49 pm

Hi,

I think I encountered a bug in the spellchecking feature:
Say the language in the "Text" style, base is: French
Say the language in the "Text" style, variation C (same as base but italicized) is: latin

When I insert an expression in latin inside a phrase in French, the last word of the latin expression is considered in French and indicated as wrongly spelled by the spellchecker. For example:

"It seems it could rain (pluere multum apparet) soon in the afternoon" : Mellel will display 'apparet' with a red background, and the same without parentheses.

Thanks for this very helpful software.

Manu

Manu31
Read the guide!
Posts: 35
Joined: Mon Aug 18, 2014 5:34 pm
Location: Toulouse, France

Re: spellchecking bug with style variation

Post by Manu31 » Tue Mar 13, 2018 9:40 am

I discovered that in footnote style, spellchecking apparently doesn't take into account the language setting. For example, spellchecking will highlight all the text in latin in my footnotes, even when its language property has been changed to Latin.

Manu.

Manu31
Read the guide!
Posts: 35
Joined: Mon Aug 18, 2014 5:34 pm
Location: Toulouse, France

Re: spellchecking bug with style variation

Post by Manu31 » Tue Mar 20, 2018 4:51 pm

MY MISTAKE!

I realized that my language settings had been changed when updating to Mellel 4. For anyone interested, here is the way to fix spellchecking when using multiple languages in a document:
- go to Mellel Preference>Language
- For each language selected in the left list, select on the right: 1. The OpenType language if there's one specific available (e.g. for French, it will be "Norme française") ; 2. Spellchecking has to be associated with the corresponding dictionary and if no dictionary is available, leave it on "none" ; 3. keyboard should be associated the language.

Hope this helps.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests