No page number on first page of each chapter

For all things Mellel

Moderators: redlers, Eyal Redler, Ori Redler

Post Reply
joseph_anton
Knows everything, can prove it
Posts: 103
Joined: Sun Jun 04, 2017 4:07 am

No page number on first page of each chapter

Post by joseph_anton » Sat Mar 24, 2018 5:41 pm

Is there any easy way to tell Mellel not to show a page number on the first page of each chapter?

Icelander
Knows everything, can prove it
Posts: 191
Joined: Mon Aug 18, 2014 10:59 pm

Re: No page number on first page of each chapter

Post by Icelander » Sat Mar 24, 2018 11:53 pm

joseph_anton wrote:
Sat Mar 24, 2018 5:41 pm
Is there any easy way to tell Mellel not to show a page number on the first page of each chapter?
Yes.

1. Open your Page style from the Page palette and tick the "Different first page" box in the lower left corner. Then
2. Insert "Page style break" from Insert -> Breaks after each chapter.

joseph_anton
Knows everything, can prove it
Posts: 103
Joined: Sun Jun 04, 2017 4:07 am

Re: No page number on first page of each chapter

Post by joseph_anton » Sun Mar 25, 2018 3:59 pm

Thanks for this pointer, Icelander!
Icelander wrote:
Sat Mar 24, 2018 11:53 pm
1. Open your Page style from the Page palette and tick the "Different first page" box in the lower left corner. Then
2. Insert "Page style break" from Insert -> Breaks after each chapter.
I think I must be missing something here. When I open the Page palette and select the style I am working with, I am indeed able to select "Different first page", which correctly suppresses the page number on page 1 of the first chapter, but not the first pages of other chapters. I tried inserting a "Page Style Break" before each chapter using the Auto-Title flows, but that seems to result in the page number being reset to one on the first page of the second chapter. I obviously need continuous numbering throughout the chapters.

Is there something I am missing here? Perhaps I'm not looking in the right place.

Icelander
Knows everything, can prove it
Posts: 191
Joined: Mon Aug 18, 2014 10:59 pm

Re: No page number on first page of each chapter

Post by Icelander » Mon Mar 26, 2018 5:13 pm

joseph_anton wrote:
Sun Mar 25, 2018 3:59 pm
Is there something I am missing here? Perhaps I'm not looking in the right place.
Assuming your document has only one Page style, open the Page palette and click on the Attributes tab. Deselect "Start at:"
This should enable continuous numbering throughout the chapters.

joseph_anton
Knows everything, can prove it
Posts: 103
Joined: Sun Jun 04, 2017 4:07 am

Re: No page number on first page of each chapter

Post by joseph_anton » Mon Mar 26, 2018 5:47 pm

Actually, I have two page styles in my document: one is for the front matter with pagination in Roman numerals, the second is for the body of the text, with pagination in Arabic numerals.

Icelander
Knows everything, can prove it
Posts: 191
Joined: Mon Aug 18, 2014 10:59 pm

Re: No page number on first page of each chapter

Post by Icelander » Tue Mar 27, 2018 2:24 am

joseph_anton wrote:
Mon Mar 26, 2018 5:47 pm
Actually, I have two page styles in my document: one is for the front matter with pagination in Roman numerals, the second is for the body of the text, with pagination in Arabic numerals.
If you have two page styles, then I assume you want the first page of the first chapter to start with the Arabic number 1. In that case you'll have to *enable* "Start at 1" in Page palette -> Attributes for the second page style.

Here is a document that shows how to do it. It has two page styles. The front matter is in Roman numerals and the rest in Arabic numerals. Since I don't know your chapter names, I just call them CHAPTER 1, CHAPTER 2, CHAPTER 3 etc. Let me know if this is what you want.

http://www.mediafire.com/file/tyo/For_J ... mellel.zip
Last edited by Icelander on Tue Mar 27, 2018 2:33 pm, edited 1 time in total.

joseph_anton
Knows everything, can prove it
Posts: 103
Joined: Sun Jun 04, 2017 4:07 am

Re: No page number on first page of each chapter

Post by joseph_anton » Tue Mar 27, 2018 10:56 am

Hi Icelander - thank you! You clearly went to lot of trouble to help me out, and I appreciate it.

The two steps I needed to take to replicate what you had done were:

- In title flows, insert page style break before each chapter
- with pages 2 - end selected, de-select the "Start At" button in the Attributes section of the Page palette

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests