Slow while editing

For all things Mellel

Moderators: Eyal Redler, redlers, Ori Redler

Post Reply
jvictorcabral
New to all this
Posts: 2
Joined: Sun Jun 28, 2020 4:32 pm

Slow while editing

Post by jvictorcabral »

I am working on a file (currently ~ 140mb) with multiple images, and the file is located in Mellel's folder within iCloud Drive. I noticed that it is quite often that it glitches or freezes for a few seconds if I try to edit some table or create a new auto-title.. or any different task other than just writing in the body of the text. I have a MacBook Air M2 with plenty of storage available, so I don't think hardware is an issue. Is there any tip to make Mellel more fluid while working on a file with many images?

I was considering splitting the document (images apart), but I'm also using cross-references, so it could end up messing that up.

Thanks for the help!
DavidH
Knows everything, can prove it
Posts: 109
Joined: Wed Mar 26, 2008 9:13 pm

Re: Slow while editing

Post by DavidH »

I’ve never had this sort of trouble with Mellel myself, so I’m speculating.

If iCloud is having a hard time keeping up with your edits of such a large file, the problem might go away if you did your editing on a local copy of your document that isn’t being backed up to iCloud. Another possible cause of trouble is the sheer size of your image files, something that can slow down a lot of apps.

If images are the culprit, you might open a copy of an image in Preview and select Tools > Adjust Size. That shows you the original dimensions of your image, its resolution in pixels / inch, and the current total file size of the image. If the resolution is a lot more than you need, you can trim the file size by checking Scale proportionally and Resample image and selecting a new (lower) resolution. The dialogue box will show you how much this will shrink the file. Hit OK to see how the shrunken image will look, and hit Save only if you’ve picked a new resolution that makes you happy. You could then put the shrunken copies in place of the originals in your Mellel document — keeping the originals in a safe place, of course — and see if that speeds up your editing.

If you are sure you need the full resolution of all your images, you could speed up Mellel for the time being by replacing each image with brief piece of placeholder text while you edit, putting the images back only when you are done editing.
Amontillado
Knows everything, can prove it
Posts: 125
Joined: Fri May 04, 2018 4:00 am

Re: Slow while editing

Post by Amontillado »

I bet the performance is tied to iCloud operations.

I set up a test "lorem ipsum" file with a dozen images. I've done this before but I think I just tested things like scrolling and finding unique text.

Images didn't seem to slow editing down. Either with or without images sprinkled through the document, inserting text at the beginning, middle, and end didn't seem to be affected by the images. Length of text seemed to be the determining factor.

On an Intel iMac, typing close to the beginning of a 2,000,000 word document had noticeable lag, enough lag to be distracting. In the middle, lag was prominent. At the end of the document there was virtually no lag.

At 1,000,000 words, there was some lag when inserting text at the beginning, about like entering text at the midpoint of a 2,000,000 word document.

Editing was pretty much keeping up with keystrokes at the beginning of a half million word document.

For comparison, if my sources are correct, 2,000,000 words is about like two volumes of Encyclopedia Britannica.
Eyal Redler
Co-founder
Posts: 669
Joined: Thu Oct 27, 2005 9:15 am

Re: Slow while editing

Post by Eyal Redler »

It seem so me as if the issue here is with the automatic backup or automatic save of the file. Have a look at Mellel > Preferences / Open & Save "Automatic Backup" and if the value is low (like a couple of minutes), try increasing it so that a backup is only saved every 30 minutes or so (this is the default) and see if this makes a change.
Eyal Redler
----------------------
Co-Founder and Owner at Mellel
Facebook: http://www.facebook.com/mellelwordprocessor
YouTube: http://www.youtube.com/user/MellelRedlex
jvictorcabral
New to all this
Posts: 2
Joined: Sun Jun 28, 2020 4:32 pm

Re: Slow while editing

Post by jvictorcabral »

Thank you all for the suggestions. Increasing the autosaving time did the trick. It was set as every minute, and then I switched to 15 min. It only lags when I save it manually, probably related to the file's size. Thanks again!
Eyal Redler
Co-founder
Posts: 669
Joined: Thu Oct 27, 2005 9:15 am

Re: Slow while editing

Post by Eyal Redler »

If you are willing to share the file with us (Mellel) that would be great, we might be able to use it to improve the saving performance.
Eyal Redler
----------------------
Co-Founder and Owner at Mellel
Facebook: http://www.facebook.com/mellelwordprocessor
YouTube: http://www.youtube.com/user/MellelRedlex
Post Reply