footnotes in files exported to rtf

For all things Mellel

Moderators: redlers, Eyal Redler, Ori Redler

Post Reply
Shelly Harrison
Already downloaded the guide
Posts: 27
Joined: Fri Apr 01, 2011 6:29 am
Location: Gold Coast, Australia

footnotes in files exported to rtf

Post by Shelly Harrison » Sun Jan 19, 2020 9:17 pm

When I export a Mellel 4 file to rtf the footnote symbol attributes are changed. The continuous numbering of the original Mellel file is changed to restart with page, and the note symbol font and size in the Mellel file are changed to Helvetica Neue 11, which I gather is a default. Is there a way of getting round this behaviour when exporting to rtf?

Icelander
Knows everything, can prove it
Posts: 260
Joined: Mon Aug 18, 2014 10:59 pm

Re: footnotes in files exported to rtf

Post by Icelander » Wed Jan 22, 2020 4:22 pm

Hi Shelly,
The continuous numbering of the original Mellel file is changed to restart with page
I think the culprit are the settings in the program you are using to open the RTF with. Word processors usually have an import template, which may or may not be the same as the default template you use when you create a new document with that program. If this template is set to restart footnotes every new page, then it overrides your Mellel file with its continuous numbering. So, make sure footnotes in the import program are set to continuous numbering before the document is imported.
the footnote symbol attributes are changed […] and the note symbol font and size in the Mellel file are changed to Helvetica Neue 11 […]
Font and size of the Note symbol are determined by the Note symbol style in the target program; it must, as far as I understand, match the Note symbol style in Mellel.

In my test, both Nisus Writer Pro and the latest version of MS Word showed continuous numbering after import, and both the Reference symbol and the Note symbol were correctly rendered… , but only as long as they were superscripted or didn't have brackets, a dot or hyphen, i.e. (#), [#], #. and #-

Since superscripts are retained, the question at this stage is: how can we then make the brackets or the dot a part of the style in the target program? It took me only 2 seconds to make the Note symbol style in Nisus match Mellel's style. The result looked perfect. In MS Word I did not find any way to make brackets or a dot a part of the style.

When I imported the RTF file with the enhanced Note symbol style from Nisus into Word, all brackets were preserved.

So, to make a long story short: if I were occasionally exporting Note symbols with brackets from Mellel to Word, I would use Nisus as a go-between; and if I were to do this on a regular basis, I would create a new Note symbol style in Nisus, matching your favorite Mellel style, and add it to the default layout, the so called "Nisus New File." After having done that, I guess there shouldn't be any need for modifying the style after import.

As I already said, MS Word doesn't allow us to do this, so, as far as I can see, you have four options: [1] use Nisus as a go-between, [2] insert the brackets per Find & Replace in Word, [3] not use brackets or a dot at all, …or [4] use only superscripts.

Shelly Harrison
Already downloaded the guide
Posts: 27
Joined: Fri Apr 01, 2011 6:29 am
Location: Gold Coast, Australia

Re: footnotes in files exported to rtf

Post by Shelly Harrison » Thu Jan 23, 2020 12:13 am

Thanks for the information. I was still confused but your suggestion about Nisus helped me figure out what's going on. Or at least I think so.

When I opened the Mellel-exported rtf in Nisus, the notes were indeed numbered continuously. (I've set footnote style is set to continuous numbering in both apps.) But, when I then open that same rtf in Mellel the footnote style has been switched to restart every page.

It seems that when Mellel imports an rtf, even one originally exported from Mellel in which footnote numbering is continuous, the footnote numbering reverts to restart every page. The 'fix' is ridiculously simple of course; just reset the numbering to continuous.

What I don't get is why Mellel seems to default to restart every page numbering when it imports an rtf, even one it created.

Icelander
Knows everything, can prove it
Posts: 260
Joined: Mon Aug 18, 2014 10:59 pm

Re: footnotes in files exported to rtf

Post by Icelander » Thu Jan 23, 2020 11:42 am

What I don't get is why Mellel seems to default to restart every page numbering when it imports an rtf, even one it created.
If I'm right about an import template controlling the footnote position, then we could try to change that template.

If we execute the File > New menu command, an "Open Template" window comes up and it shows 6 Default documents: Default A4, Default Letter, Default A4 Classic, etc.

These default files, called Factory Templates, all have a factory setting set to 'Restart every page.' I'm not sure, but perhaps one of these files is used by Mellel as an import template. That could explain, as I have already said, why the footnote position always reverts back to 'Restart every page' when a RTF is imported (back) into Mellel.

We could verify this assumption if we change those Factory Templates. To do that we need to quit the program, then right-click on the Mellel icon in the Application folder and choose Contents > Resources > English.Iproj > factory_templates. Then open, for example, the file called "Default A4.meltem", change the default footnote position and save the file again as template, then quit and restart Mellel. Take note, each language has its own Factory Templates folder.

By the way, please help me here, I can't think of a scenario where one would rather prefer 'Restart every page' to 'Continuous.' Can't remember having ever seen a scholarly paper written like that.

Or perhaps the whole monkey business is just a plain bug after all…

Now is the right time for Eyal to chime in!

laup
Knows everything, can prove it
Posts: 298
Joined: Tue Aug 22, 2006 4:13 am
Location: Topanga, California

Re: footnotes in files exported to rtf

Post by laup » Sun Feb 02, 2020 7:28 pm

If for some reason, one is labeling footnotes with *, dagger, etc., rather than numbers, then restarting each page is preferable. A rationale for that is when footnotes are used only for, e.g., definitions, while endnotes are used for all other kinds of notes (citations, elaborations, etc.).
Paul

Icelander
Knows everything, can prove it
Posts: 260
Joined: Mon Aug 18, 2014 10:59 pm

Re: footnotes in files exported to rtf

Post by Icelander » Mon Feb 03, 2020 10:49 am

laup wrote:
Sun Feb 02, 2020 7:28 pm
If for some reason, one is labeling footnotes with *, dagger, etc., rather than numbers, then restarting each page is preferable.
Yes, you are right, Paul. That makes sense. I remember having seen that.

Thanks for clarifying.

Icelander
Knows everything, can prove it
Posts: 260
Joined: Mon Aug 18, 2014 10:59 pm

Re: footnotes in files exported to rtf

Post by Icelander » Mon Feb 03, 2020 11:22 am

Icelander wrote:
Thu Jan 23, 2020 11:42 am
These default files, called Factory Templates, all have a factory setting set to 'Restart every page.' I'm not sure, but perhaps one of these files is used by Mellel as an import template.
A while ago we asked Eyal for conformation. He is obviously not going to answer, so I went on, alone…

Yes, I was right. I changed the default footnote position of the "Default A4.meltem" template, and now, every time I import a file with footnotes, the footnote numbering position is set to "Continuous."

Problem resolved!. :–)

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests