Page style

For all things Mellel

Moderators: Eyal Redler, redlers, Ori Redler

Post Reply
Vaissiere
Already downloaded the guide
Posts: 32
Joined: Sun Dec 26, 2010 10:46 am
Location: Paris

Page style

Post by Vaissiere »

Dear all

I cannot figure out how to do something, or may be it is a bug?

My problem is the following
My whole text is in portrait format:
-in edit styles ->edit page styles in the lower right part of the window, the greyed option is the portrait one, not the landscape one
-similarly in palette Page -> Margins&orientation the greyed option is the portrait one
-the layout of the text itself, on screen and printing, is indeed in portrait
-in the file-> printing format the portrait mode is selected

BUT

-in edit styles ->edit page styles, the image of the page is in landscape ! To have it in portrait, I have to click on landscape on the lower left corner (and then my text is in landscape)

It is as if landscape/portrait have been inverted in edit styles ->edit page styles

I cannot explain this. Is this a bug ? Am I alone with this problem? I have the same problem if I create a new blank document.
It is inconvenient to edit the page style, especially the margins (I do not know why only the left and right margins are directly editable on this window, BTW)

any idea?

thanks

Etienne
Icelander
Knows everything, can prove it
Posts: 295
Joined: Mon Aug 18, 2014 10:59 pm

Re: Page style

Post by Icelander »

Hello Etienne,

If we refer to menu commands, we should always write their names exactly as they appear in (the English version of) Mellel, including capital letters and quotes, if that's applicable. That's helpful when other forum members try to reproduce issues.
-in edit styles –> edit page styles
"-in edit styles" exists nowhere, and this makes it hard to follow you.

What I think you mean is this:
Styles > Page Style > Edit "Page style"…


Having said that, allow me to jump to the second part of your post, beginning with BUT:
BUT in Styles > Page Style > Edit "Page style"…
the image of the page is in landscape!

This is not the case by me. The image is in portrait. Perhaps this has something to do with the macOS version you are on (?). I'm on High Sierra (10.13.6)
To have it in portrait, I have to click on landscape on the lower left corner (and then my text is in landscape)
There is nothing in the lower left corner that allows you to change the orientation. In the left corner you only have (1) Different first page and (2) Different Odd/Even pages. Perhaps you mean in the lower *right* corner? The buttons for changing the orientation from portrait to landscape and visa versa are located in the *right* corner.

It is inconvenient to edit the page style, especially the margins (I do not know why only the left and right margins are directly editable on this window, BTW)
If I managed to follow your description correctly, then you should be able to edit all margins, including top and bottom, by just dragging the borders of the page image with the mouse.

If I misunderstood something, then I appologize.
Amontillado
Knows everything, can prove it
Posts: 92
Joined: Fri May 04, 2018 4:00 am

Re: Page style

Post by Amontillado »

I think the grayed option is the one selected - is that a correct interpretation?

The portrait option in each case is grayed (selected) and it prints in portrait.

Go into the page style editor and click back and forth between the two orientations. The layout follows the one that is gray.

Perhaps gray means that's the button that's depressed, not that it's unavailable. I think both orientations will always be available for use.
Vaissiere
Already downloaded the guide
Posts: 32
Joined: Sun Dec 26, 2010 10:46 am
Location: Paris

Re: Page style

Post by Vaissiere »

Thanks for the answers, and sorry for the slip: yes I meant lower right corner. But my problem is indeed there. In this "edit styles ->edit page styles" page the upper big part (with the possibility to change the margins, etc.) is in landscape while simultaneously, on this very page, the choice "portrait" on the lower right side is greyed

yours

Etienne
Amontillado
Knows everything, can prove it
Posts: 92
Joined: Fri May 04, 2018 4:00 am

Re: Page style

Post by Amontillado »

Is there anything weird in File->Page Setup?

If you choose a different page geometry does the problem go away?
DavidH
Knows everything, can prove it
Posts: 86
Joined: Wed Mar 26, 2008 9:13 pm

Re: Page style

Post by DavidH »

Amontillado’s suggestion sounds right to me. If the orientation in Page Setup were set to Landscape instead of Portrait, and you are using a template like Blank A4 that expects to be opened in Portrait mode, you might get the kind of reversal you report.

Another thing worth checking is whether you see anything unusual in the Print dialogue box when you select the Print command. Ordinarily Presets should be showing Default Settings and the control below the Page Range should be showing Mellel 5.

Some templates, e.g. the three envelope templates, are set to open in Landscape mode. Do you see the same odd behavior with them?
Post Reply